Von Windows 8 auf Windows 10: Eine unendliche Geschichte …

Ja, ich bin ein sogenannter „Early Adopter“. Ich will immer die neueste Version, manchmal auch die Betaversion. Ich habe lange Jahre für die Computerzeitschriften amigaOS und AMIGAplus Artikel geschrieben, unfertige Software und neue Hardware getestet. Geht nicht gibt’s bei mir nicht, irgendwie finde ich schon eine Lösung. Doch ein einfaches Upgrade meines Dienst-Laptops von Windows 8 auf Windows 10 hat mich an die Grenzen meiner Möglichkeiten gebracht:

Windows 8 auf Windows 8.1

Das automatische Upgrade auf Windows 10 wird nur unter Windows 8.1 angeboten, nicht unter Windows 8. Leider hatte das Upgrade auf Windows 8.1 auf diesem PC nie funktioniert, aber das war mir nicht ganz so wichtig gewesen. Im Lauf von zwei Jahren hatte ich nun wirklich alles ausprobiert: Upgrade-Cache löschen, diverse Reparaturoptionen, alle Treiber aktualisiert, von denen ich aktuellere Versionen finden konnte und und und. Alles ohne Erfolg: Jedes Mal nach zwei, drei Stunden Installations-Download kam beim ersten Start nach der Installation ein „Bluescreen“ ohne hilfreiche Meldung und anschließend „Wir haben Ihre alte Windows-Installation wiederhergestellt.“ Das habe ich im Lauf der Zeit mindestens zwanzig Mal probiert, mit unterschiedlichen Optionen.

Härtere Bandagen

Schließlich verzichtete ich darauf, meine Programminstallationen und so weiter mit zu übernehmen. Wozu gibt es die Funktion „Windows auffrischen“ oder so ähnlich? Also beherzt ans Werk. Und was sagt Windows? „Es fehlen Dateien, die Funktion ist nicht möglich“.
Nun also ein DVD-Abbild von Windows 8 heruntergeladen und komplett neu installiert. Dann Upgrade auf 8.1 angestoßen. Geht nicht. „Bitte erst Upgrades für Windows 8 installieren“ – 151 Stück. Super. Dann wieder: Upgrade auf Windows 8.1. Spannung, Trommelwirbel: „Wir haben Ihre alte Windows-Installation wiederhergestellt“. Gnaaah! Zur Sicherheit das Ganze nochmal wiederholt, inklusive 151 Updates sowie etwa 20 Treiberupdates – gleiches Ergebnis.

Mit einem Key für Windows 8 kann man nur Windows 8 installieren, nicht Windows 8.1 Aber es gibt auch einen Trick, wie es doch geht. http://www.pcwelt.de/tipps/Setup-DVD_fuer_Windows_8.1_herunterladen-Wind... Eigentlich ganz einfach: Mit dem Download-Tool für Windows 8 den Download der Installationsdateien beginnen (dabei muss man den Windows-Key eingeben), dann abbrechen und das gleiche mit dem Download-Tool für Windows 8.1 beginnen. Dieses Tool merkt dann: Es lieft schon ein Download, und lädt problemlos 8.1 herunter. Leider wird man bei der Installation nochmal nach dem Windows-Key gefragt. Aber wozu gibt es „generic keys“, die zwar die Installation von Windows, aber nicht dessen Aktivierung ermöglichen? Also generic key eingegeben, installiert und nachher bei der Aktivierung wieder den eigentlichen Key eingegeben. Eigentlich ganz einfach.

Jetzt aber: Windows 10!

Gleich bei der Installation von 8.1 – bzw. nach deren Abschluss – bot Windows mir das Upgrade auf Windows 10 an. Na, jetzt sollte es aber doch gehen! Also wieder ein paar Stunden gewartet … Trommelwirbel … „Wir haben Ihre alte Windows-Installation wiederhergestellt“. Übrigens mit der gleichen, nicht sonderlich spezifischen Fehlernummer (0xc1900101-0x20017), die ich jetzt schon so oft gesehen hatte.

Nächste Stufe

Man kann auch eine Windows 10 Installations-DVD herunterladen. Gesagt, getan und DVD gebrannt. Erst mal draufkommen, dass bei der Installation zwar ein Schlüssel abgefragt wird, man diesen Punkt aber auch überspringen kann. Nun, Installation läuft an, läuft und läuft … und bleibt bei 3 Prozent hängen. Stundenlang. Ausgeschaltet, nochmal probiert. Diesmal immerhin bei 4%. Ausgeschaltet, nochmal probiert. 3%.

Die ISO-Datei für die Windows-10-DVD liegt auf der Festplatte dieses Laptops, der jetzt gerade kein funktionierendes Betriebssystem hat. Also erst einmal die uralte BartPE-CD von heise herausgekramt, auf der ein lauffähiges Windows (XP? Keine Ahnung.) von CD drauf ist, um die ISO-Datei auf eine externe Festplatte zu ziehen und sie dann auf dem privaten Computer zu brennen. Ich hätte auch von CD lauffähige Linuxe da, aber das war die erste CD, die ich gefunden habe. Warum auch immer: Die Datei ist nicht mehr da. Also auf dem privaten Computer nochmal Windows 10 heruntergeladen und DVD gebrannt. Ob es diesmal funktioniert? Ob die Aktivierung überhaupt klappt?

Nun kommt zum ersten Mal im Klartext, was ich die ganze Zeit schon vermutet hatte: Ein Treiber für irgend eine Hardware fehlt. Leider sagt mir die Installationsroutine nicht, für welche. Immer wieder und immer noch der gleiche Mist: Ich soll einen Treiber suchen, aber ich weiß nicht, welchen. Erster Versuch: Die alten Installations-CDs für Windows Vista (!) einlegen, vielleicht ist was dabei, womit sich Windows 10 auch zufrieden gibt. OK – das wäre ja auch zu einfach gewesen.

Auf dem anderen Laptop die CD einlegen, alle selbstentpackenden Archive von .exe in .zip umbenennen, entpacken, auf externe Festplatte ziehen und das Installationsprogramm nochmal suchen lassen. Wie gut, dass ich DirectoryOpus habe, damit ist die ganze Umbenennerei und Entpackerei ein Kinderspiel.

Ach ja: Die Windows Vista-Installations-CD hat natürlich irgendwie einen kleinen Schaden und kann nicht mehr richtig eingelesen werden.

Gut – mit allen irgendwie gefundenen Treibern auf einer externen Festplatte scheint das Installationsprogramm zufrieden zu sein. Jetzt kam zur Abwechslung: „Die Microsoft-Lizenzbedingungen wurden nicht gefunden“. Auch mal was neues. Wahrscheinlich war ich einfach nicht da, als ich die Lizenzbedingungen abnicken sollte, und es wurde dem Installationsprogramm zu langweilig. Beim nächsten Versuch lief es wieder durch, und zwar – tadaa! Komplett!

Leider, leider geht es so nicht. Um Windows 10 mit einem Installations-Code von Windows 8 verwenden zu können, muss Windows 10 als Update eingespielt werden. Dabei wird diese Version von Windows 10 mit dieser Hardware verbunden. Also wieder zurück, Windows 8.1 installieren, so wie oben beschrieben. Diesmal verwende ich das schon lange eingerichtete Windows Live-Konto und werde zur Überprüfung erst einmal aufgefordert, einen per SMS zu empfangenden Code einzugeben. Ratet mal, wer zu Hause keinen Handy-Empfang hat …
OK, per Mail soll es auch funktionieren. Nur kommt die Mail ewig nicht. Nun, es geht auch ohne eine „Sicherheitsüberprüfung“.

Unter Windows 8.1 das Upgrade auf Windows 10 angestoßen, ein paar Stunden gewartet und … juhu! „Wir haben Ihre alte Windows-Installation wiederhergestellt.“

An diesem Punkt bin ich erst einmal drei Wochen in Urlaub gefahren.

Anschließend dachte ich, es sei im Augenblick gar kein Betriebssystem installiert und war dann recht erstaunt, dass mich ein Windows begrüßte, dessen Version ich erst einmal herausfinden musste. Ja, es war 8.1.

Also nochmal von DVD probiert, natürlich mit dem üblichen Ergebnis. Nochmal alle Updates für 8.1 installiert und wieder von DVD, das gleiche. Dann zur Abwechslung mal wieder in den Gerätemanager geschaut und festgestellt: Ein Bluetooth-Modul vermisst seinen Treiber. Den gesucht, gefunden, neuer Versuch. Wieder kein Erfolg.

Jetzt wird gebastelt!

Irgendwie scheinen bei Dell das Bluetooth- und das WLAN-Modul zusammenzuhängen. Ob es vielleicht nur ein Modul ist, auch wenn auf der Hardware ausschließlich WLAN draufsteht? Ein weiteres Modul ist jedenfalls nicht zugänglich, also baue ich kurzerhand das aus, auf das ich Zugriff habe, und beschaffe dem PC erst mal eine kabelgebundene Internetverbindung statt WLAN. Trommelwirbel … „Wir haben Ihre alte Windows-Version wiederhergestellt.“

Nun ja, wo wir schon mal dabei sind, deaktiviere ich halt noch ein paar unnütze Geräte im Gerätemanager und probiere es nochmal aus. Nutzt nix.

In diesem Beitrag http://www.borncity.com/blog/2013/11/01/windows-8-1-upgrade-error-0xc190... finde ich schließlich den Hinweis, dass es (beim Upgrade von Windows 8 auf 8.1, aber was soll's) oft Probleme gibt, wenn zwei Festplatten im System sind, insbesondere wenn die System-Platte eine SSD ist, auf die der Inhalt der ursprünglichen Windows-Partition geklont wurde. Und dass es reicht, die zweite Festplatte für die Installation abzuklemmen. Genau meine Konfiguration. Nun ja, nichts leichter als das. Wird gleich probiert. Von DVD wieder mal die Installation gestartet. Was soll ich sagen? „Wir haben Ihre alte Windows-Version wiederhergestellt.“

Gut, das hat auch nichts geholfen. Wie wäre es mit einer Installation im abgesicherten Modus? Geht auch nicht, natürlich. Bringt mich aber auf eine weitere Idee:

Jetzt noch BIOS!

Ich deaktiviere im BIOS alle, wirklich alle Features. Lasse die Installation laufen. Und – voilá! Windows 10 ist installiert! Jetzt alle Features wieder aktivieren, neu starten, gebannt auf den Bildschirm starren … irgendwas von „Boot device not found“. Immerhin mal was Neues. Während ich was anderes tue, startet Windows einfach ein paar Mal neu und fragt mich dann, ob es sich selbst reparieren soll. Aber gerne doch! Also noch ein, zwei Neustarts – und auf einmal läuft alles!
Beim Wiederanschließen von WLAN-Modul und zweiter Festplatte gab es erstaunlicherweise keinerlei Probleme. Jetzt „nur noch“ die Laufwerksbuchstaben wieder anpassen, alle Programme wieder installieren und in zwei, drei Tagen bin ich wieder einsatzbereit.

Ehrlich gesagt: So wichtig ist ja das Upgrade auf Windows 10 auch nicht. Aber so was packt mich einfach an der Ehre. Und es hat ja schließlich doch noch geklappt. :-)

Lizenz: 

Creative Commons Licence